Partial Outage - Novasis Parent/Guardian Proxy Access

Incident Report for Villanova University IT Status

Resolved

8/5/26 1:00pm Parent/Guardian Proxy login access should now be restored.
Posted Aug 05, 2026 - 13:00 EDT

Investigating

Users are experiencing technical difficulties with the Proxy Access login page and Forgot Password process. Please do not attempt to log into proxy access or change your password while the issue is being investigated. We apologize for the inconvenience.
Posted Aug 04, 2026 - 13:05 EDT
This incident affected: Administrative & Enterprise (Ellucian Banner ERP).