Degraded Performance: Microsoft 365

Incident Report for Villanova University IT Status

Resolved

Microsoft has provided an update that services have been restored for all impacted customers.
Posted Mar 06, 2026 - 14:09 EST

Investigating

Microsoft is investigating degraded performance with various services. Affected applications include:
-Microsoft 365 admin center
- SharePoint Online
- Microsoft Teams

We will provide another update as more information becomes available.
Posted Mar 06, 2026 - 12:04 EST
This incident affected: Collaboration & Communication (Microsoft 365).