Degraded Performance: Single Sign-On

Incident Report for Villanova University IT Status

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 12:47 EDT

Investigating

University Technology Services is investigating intermittent 502 and 503 errors affecting applications using Single Sign-On. If you experience this, try refreshing the page in your browser. We will provide another update as more information becomes available.
Posted Jul 16, 2026 - 11:00 EDT
This incident affected: Identity & Access (Single Sign-On).