Outage: Emma

Incident Report for Villanova University IT Status

Resolved

Emma has reported that the SSO-related login issues have been resolved.
Posted Aug 04, 2026 - 16:28 EDT

Identified

Emma has identified the issue and a fix is being applied. For more information, please visit Emma's status page: https://status.myemma.com/incident/698026
Posted Aug 04, 2026 - 14:30 EDT

Investigating

University Technology Services is currently investigating a reported outage of Emma for non-admin users. Please check back for updates.
Posted Aug 04, 2026 - 13:49 EDT
This incident affected: Collaboration & Communication (Emma Mass Email Marketing Platform).