Partial Outage: Single Sign On

Incident Report for Villanova University IT Status

Resolved

The incident has been resolved. If you are still experiencing issues with Single Sign-On, then please contact the Service Desk.
Posted Jun 24, 2026 - 10:39 EDT

Investigating

University Technology Services is investigating an intermittent performance degradation issue affecting Single Sign-On with Villanova Accounts. Affected applications include any services with Single Sign-On. We will provide another update as more information becomes available.
Posted Jun 23, 2026 - 09:03 EDT
This incident affected: Identity & Access (Villanova Account).