Degraded Performance: BitLocker Recovery on University-managed Windows Device

Incident Report for Villanova University IT Status

Resolved

This problem has been resolved by rolling back a device policy while further investigation takes place.
Posted Mar 20, 2026 - 09:12 EDT

Update

Technology Services continues to investigate the issue with devices prompting for BitLocker recovery keys.
Posted Mar 17, 2026 - 10:26 EDT

Investigating

University Technology Services is investigating increased reports of BitLocker Recovery on University-managed devices. Users can retrieve a recovery key by contacting the Service Desk or following the instructions in this KB article from another device: https://villanova.teamdynamix.com/TDClient/2759/UNIT/KB/ArticleDet?ID=159016
Posted Mar 16, 2026 - 08:53 EDT
This incident affected: Devices & Software (University-Managed Devices).