3/24/26 - Partial Outage: UKG Ready

Incident Report for Villanova University IT Status

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 16:30 EDT

Investigating

University Technology Services is investigating a partial outage with UKG Ready. At this time, supervisors may be unable to view employee's time and attendance in UKG Ready. UTS teams are working to identify and resolve the issue.

Other affected applications include Cognos Analytics and University Directory. We will provide another update as more information becomes available.
Posted Mar 24, 2026 - 08:30 EDT
This incident affected: Data & Analytics (IBM Cognos Analytics), Identity & Access (University Directory (directory.villanova.edu)), and Administrative & Enterprise (UKG Ready).