University Technology Services has completed maintenance on NOVASIS and Banner Admin on Sunday, June 14, focused on Single Sign-On (SSO). Access may have been intermittently unavailable during the maintenance window.
This update introduces a more modern, unified login experience aligned with systems such as MyNova, Brightspace, and other services, improving security, reliability, and performance. As part of a phased transition, a small number of NOVASIS pages will temporarily continue to display the legacy login screen.
If you are experiencing issues or have questions, please contact the Service Desk.
Posted Jun 14, 2026 - 10:51 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 14, 2026 - 07:00 EDT
Scheduled
University Technology Services will perform rescheduled maintenance on NOVASIS and Banner Admin on Sunday, June 14, from 7 a.m. to 3 p.m. During this time, access to NOVASIS and Banner Admin will be intermittently unavailable as the University completes the transition of Banner and NOVASIS to the Single Sign-On (SSO) system. This work, originally planned for June 5, was postponed as a precaution after a potential risk was identified during implementation. The update will introduce a more modern experience and a unified login process aligned with systems such as MyNova, improving security, reliability, and performance. Please complete time-sensitive tasks in advance. For questions, contact the Service Desk.
Posted Jun 05, 2026 - 14:54 EDT
This scheduled maintenance affected: Administrative & Enterprise (Ellucian Banner ERP).