Partial Outage: Duo | Authentication

Incident Report for Villanova University IT Status

Resolved

As of 12:55 p.m., Duo has resolved the incident. If you are still experiencing issues with Duo, please submit a ticket through the Services and Support Portal.
Posted Feb 23, 2026 - 13:04 EST

Monitoring

Duo has deployed a fix for the gateway timeouts and is now seeing successful authentications. We are currently monitoring for any further issues. For additional information, please visit Duo's Status page at https://status.duo.com. Please continue to check back for updates.
Posted Feb 23, 2026 - 12:12 EST

Update

Microsoft is currently investigating an issue where users in the United States may experience 504 gateway timeout errors when attempting to access services that require Multi-Factor Authentication (MFA). For additional information, please visit Microsoft's Status page at https://status.cloud.microsoft. Please continue to check back for updates.
Posted Feb 23, 2026 - 11:37 EST

Investigating

University Technology Services is currently investigating reports of a partial Duo authentication outage affecting some users. Please check back for updates.
Posted Feb 23, 2026 - 09:56 EST
This incident affected: Identity & Access (Duo Multi-Factor Authentication).